TheDieselPage.com Forums  
2014 - TDP's 19th Year
What's New: | Feature Articles: | Product Reviews: | Member's Area: | Subscribe:
Duramax 6600 Diesel Page | Advertiser's Section | Classified Ads | Photo Album | Diesel Books, GM Licensed T-shirts


Go Back   TheDieselPage.com Forums > The Diesel Page Member Forums > 6.5L Turbo Diesel
Register FAQ Members List Photo Album Mark Forums Read

6.5L Turbo Diesel 1992-00 6.5TD - Discussion forum for the 6.5L engine.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-28-2006, 01:01 PM
6.2 G-30 van 6.2 G-30 van is offline
Newbie
 
Join Date: Mar 2006
Posts: 5
Default 4L80E trans no overdrive or lockup

Hello all , I hope this is the correct forum to post my question under. When I lose overdrive and torque converter lockup on my 1993 4L80-E transmission, I spray engine degreaser then blast with carburator cleaner around the outside of the fuel injection pump (driver side) .

This last time the trick didn't work, so I took off the throttle position sensor from the passenger side of the pump and took it apart to clean it. This helped smooth the shifts and there were no more delayed upshifts, but still no over-drive or lock up. I even disconnected the batteries to clear the computer.

This same effect happened long ago when I discovered one of the thin wires broke off the computer harness connector (I remove the computer at the end of each day to prevent its theft.) After I fixed the wire the trans shifted normal.

Is there an electronic solenoid that needs replacing on the trans? Thank you in advance for any suggestions.

Frank
Reply With Quote
  #2  
Old 03-28-2006, 02:39 PM
john8662's Avatar
john8662 john8662 is offline
modeRATOR
 
Join Date: Sep 2001
Location: Lubbock TX, USA
Posts: 4,083
Default

Check for codes, you might get a code for the tranny that could point to where the problem is.

At the very minimum, I think that replacing the TPS would be a wise move!

Solenoids have been problematic on early 4L80E transmissions, so it's possible that one of them (the one that controlls OD) could be malfunctioning.

Hopefully others that are tranny guru's will chime in here...
Reply With Quote
  #3  
Old 03-29-2006, 09:19 AM
LanduytG LanduytG is offline
Supporting Vendor
 
Join Date: Mar 2000
Location: Greenfield, In
Posts: 1,406
Default

First thin I would do is take a look at the brake switch. Then move to the connector on the trans itself. Also if the cruise control does not work its a good indication of these two areas.

Greg
__________________
Diesel Page Supporter
Greg Landuyt
Lubrication Specialist, LLC.
1-888-306 4255
greg@lubricationspecialist.com
http://www.lubricationspecialist.com
Reply With Quote
  #4  
Old 03-31-2006, 09:34 PM
damork damork is offline
Enthusiast
 
Join Date: Apr 2000
Location: IL
Posts: 810
Default

A brake switch is not too expensive, if I recall it is around $40. I'm about to change mine out although I bought it a while ago for the same reason. GM techs say that removal is simplified if you don't try to save the retainer circlip and just plan on buying a new retainer when you install the new switch. It really is located in a cozy spot.
__________________
350k+ miles of 6.2/6.5 experience
Reply With Quote
  #5  
Old 04-01-2006, 12:14 AM
signgrafix signgrafix is offline
Enthusiast
 
Join Date: Jan 2006
Location: Louisville Kentucky
Posts: 85
Default

if you do not fiqure out the problem by Monday. I will ask a friend of mine who owns a Transmission Shop for you.
__________________
1994 chevy turbo diesel 3500 4WD extended cab.
4 inch Pinnacle exhaust from the turbo back
Kennedy OPS harness (yet to be installed)
FSD cooler (yet to be installed, planning on placing in fender to pick up air from intake)
Bet top extendable mirrors.
Reply With Quote
  #6  
Old 04-25-2006, 01:44 AM
bluuzman bluuzman is offline
Blues harpist
 
Join Date: Apr 2006
Location: Finland (Arctic Circle)
Posts: 31
Default

Hi, I recently lost the TC lockup and cruise (4L80E). At first, they did work from time to time but TC had quite rough action (like on/off). Sometimes everything worked just fine until they were lost completely.

Got code 28 pointing to pressure switches detecting the shift position. The problem was probably in the multi-pin connector at the transmission but as I did not really fix anything, just disconnected and connected the plug a few times, code disappeared and the lost functionality came back, I can not be sure what was really the reason.

-ari
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:25 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 1996-2014 by TheDieselPage.com - All Rights Reserved