TheDieselPage.com Forums  
2014 - TDP's 19th Year
What's New: | Feature Articles: | Product Reviews: | Member's Area: | Subscribe:
Duramax 6600 Diesel Page | Advertiser's Section | Classified Ads | Photo Album | Diesel Books, GM Licensed T-shirts


Go Back   TheDieselPage.com Forums > Chevrolet & GMC 2500HD/3500 Light Trucks > Duramax 6600
Register FAQ Members List Photo Album Mark Forums Read

Duramax 6600 Discussion Forum for the Duramax 6600 Diesel Engine, including the LB7, LLY, LBZ & LMM engine specific topics.

Reply
 
Thread Tools Display Modes
  #1  
Old 07-29-2012, 09:04 PM
Bill Robinson Bill Robinson is offline
Newbie
 
Join Date: Jul 2012
Location: Tennessee
Posts: 5
Default Check Engine light

I hope I have this in the right forum
I have a 2006 GMC SLT 2500 Duramax. 6.6 Diesel
I purchased it in January of 2012 with 89,000 miles
I now have 94,0000 miles on the truck.

The previous owner took VERY good care of the truck
He installed 4 inch Magna Flow exhaust. He did not install the Muffler. A straight section is welded there instead. I do have the Muffler, still in the plastic wrap. The previous owner also had an EDGE programmer in the truck but removed it before selling it. I wish he had not. It cost $800.00.

About 6 weeks after I bought the truck the check engine light came on. It stayed on for a couple days then went off. It did this a few times so I took it to the dealer. They read the codes and the Tech asked me if there was a chip in the truck? I said I didn't know. I still don't. He said the code was indicating something with the Turbocharger. But he didn't know what. He said it was probably minor and to not worry about it.
I paid $80.00 for that.

After that the Check Engine light would come on every couple weeks then go off.

Last week the Check Engine light came on and does not go off. I decided I could read the codes myself rather than pay the dealer 80 bucks again to have him ask me what was wrong with it.

So I bought an Actron Autoscanner. It works pretty good. Gives me the codes and possible causes and possible fixes. Starting with the most common.

The problem is I know nothing about Diesel engines so the codes are mostly a foreign language to me.

The codes I am seeing
P0101 Mass or volume air control circuit range
Replace EGR valve is the first fix listed

P2563 Turbocharger Boost control position sensor A
Possible fixes listed
Replace Turbocharger
Perform Turbocharger Learned procedure
Replace turbocharger vane position control sensor
Programm power train control module

P0674 Cylinder 4 glow plug
Replace Glow plug is first fix listed.


The P2563 is the one that has me worried. I would think a turbocharger for this truck would be very expensive.
The truck runs fine. Plenty of power and MPG is about 17. I do notice a little black smoke now and again at idle and there is a little soot at the exhaust after a few days.

My big question. Could this be the result of having the EDGE programmer installed and then removed and the 4" Magna Flow exhaust.
Also is there a place where I can get the information for reprogramming these systems or is that a dealer only item.

I hope I have explained this well enough and that I have this posted in the right place.
Thanks for any help I might get.
Reply With Quote
  #2  
Old 07-29-2012, 10:05 PM
DmaxMaverick DmaxMaverick is offline
Administrator
 
Join Date: Apr 2001
Location: CA
Posts: 10,545
Arrow

Welcome aboard!

It looks like the only they got right is the P0674. Replace that glow plug, and the complaint should go away. Also, check with the dealership, it may be covered under a recall (some were). Otherwise, they aren't too costly, and simple to replace. More on that, if you need it.

P0101
May be nothing more than a dirty MAF sensor (usually is). Remove and clean it (carefully with a spray cleaner, but don't contact the element). A dirty air filter can also cause this (turbulent/reduced intake airflow). At worst, the MAF sensor needs replacement. All of the above are simple DIY'ers.

P2563
Probably a soot-fouled vane position servo, caused by excessive use of a power programmer (excessive fuel, causing excessive soot fouling, Edge is the usual suspect). The dealer (or competent shop with the equipment) can "exercise" the servo and reset the position. At worst, the servo may need replacement. Not the turbo.

The larger exhaust or lack of muffler, won't (normally) cause issues. At most, some EGR or emission related faults can appear, due to the reduced back-pressure. None serious or destructive, though. The best solution is to have the EGR circuit control and monitoring "addressed", by a quality programmer, such as Kennedy Diesel. The dealer won't "reprogram" any PCM outside of what was originally available, or allowed as an update (EGR modification/disable is not one of them).
__________________
1985 Blazer 6.2
2001 GMC 2500HD D/A
2014 Chevy Cruze Diesel
dmaxmaverick@thedieselpage.com
Reply With Quote
  #3  
Old 07-30-2012, 06:00 AM
Bill Robinson Bill Robinson is offline
Newbie
 
Join Date: Jul 2012
Location: Tennessee
Posts: 5
Default Thank you

I appreciate the quick response and the answers to my questions. I have never owned a diesel before so this helps a lot.
I can handle the DIY parts. I am fairly Mechanical. (Doing a minimal restore on a Corvette right now)
I think the previous owner probably had the engine tuned for performance.
I have considered a tune of some kind but I am just starting to learn about diesels and how they work.

I need to find a good diesel service company here in The Nashville Area.

Thanks again. I will post the results of the repairs as I get it done. I just need a manual to show me where all those parts are.
Reply With Quote
  #4  
Old 07-30-2012, 10:44 AM
DmaxMaverick DmaxMaverick is offline
Administrator
 
Join Date: Apr 2001
Location: CA
Posts: 10,545
Arrow

For manuals:

www.helminc.com (paper)

www.alldatadiy.com (online)
__________________
1985 Blazer 6.2
2001 GMC 2500HD D/A
2014 Chevy Cruze Diesel
dmaxmaverick@thedieselpage.com
Reply With Quote
  #5  
Old 07-30-2012, 04:18 PM
rapidoxidationman rapidoxidationman is online now
Enthusiast
 
Join Date: Dec 2002
Location: Teton Valley, Idaho
Posts: 610
Default

+1 on AllData. It is about $30 for a 5 year subscription and includes updated TSBs and other things the paper manual can't provide. Info can sometimes be tough to find, but so far it hasn't let me down (and I've dug as deep as you can in the top end of the engine...)
__________________
'85 Mercedes Benz 300D, for when I want to be stately.
'05 Chevy K2500 ext cab long box DMax: Everything my '03 was and so much more!

There's no point being a pessimist - it wouldn't work anyway.
Reply With Quote
  #6  
Old 08-02-2012, 06:31 PM
Bill Robinson Bill Robinson is offline
Newbie
 
Join Date: Jul 2012
Location: Tennessee
Posts: 5
Default Thanks for the info and the links

Thanks. I cleaned the MAF sensor. I also serviced the Air filter while I was in there.
I Bought some Sea Foam and also some Diesel Kleen.

I figured I'd try both. Been getting recommendations on both so why not. I drove the truck about 110 miles today pulling a 5th wheel Camper.
The truck performed fine. Plenty of power and cruised right along
The check engine light is still on. I figured I'd let it go through a few cycles or what ever it is the computer does and see if the light goes out.
If it does not I will read the codes again.
I tried to clear the codes with the code reader I got but it does not seem to do that. It has an "Erase codes" feature but I guess it only erases the codes in the Code reader, not the truck.
If the light doesn't go out after a few days I will disconnect the batteries and see if that clears the codes.
Then see what new codes I get when the light comes on.
Thanks again I will look into the online links.

BTW I was reading one forum where it said having an aftermarket straight through exhaust like Magna Flow can cause false EGR codes. Is this true?
Reply With Quote
  #7  
Old 08-02-2012, 08:15 PM
DmaxMaverick DmaxMaverick is offline
Administrator
 
Join Date: Apr 2001
Location: CA
Posts: 10,545
Arrow

You can clear the codes without a code reader, or waiting. Disconnect BOTH Batt - (negative/ground) cables (or all), and connect one of them to a Batt + cable (leaving BOTH negative battery posts/terminals connected to NOTHING, do not short circuit the batteries), connecting only the CABLES together, not the batteries. Leave for 30 minutes to an hour. Reconnect the cables and the codes/light should be clear. Just disconnecting the batteries can take a day(s) to clear the computer.

I've heard of, but not personally seen that I can recall (I've seen conditions that could have been, but not proved), an "open" exhaust cause EGR issues. Theoretically it is possible, as the expected manifold pressure change may not be sufficient enough to satisfy the computer with less exhaust back pressure. If the Cat is gone, it could be a more likely issue. If you reinstall the original exhaust system and the problem continues, then it isn't the exhaust system.

The additives may not help with EGR issues, as they leave the cylinders as gas and soot, just like the fuel (which is a problem in the first place). You can remove and clean the EGR valve manually, though.

Also, make sure you have sufficient vacuum to operate the system (test the vacuum pump/system).
__________________
1985 Blazer 6.2
2001 GMC 2500HD D/A
2014 Chevy Cruze Diesel
dmaxmaverick@thedieselpage.com
Reply With Quote
  #8  
Old 08-10-2012, 03:05 PM
Bill Robinson Bill Robinson is offline
Newbie
 
Join Date: Jul 2012
Location: Tennessee
Posts: 5
Default Thanks --- update

P2563
Probably a soot-fouled vane position servo, caused by excessive use of a power programmer (excessive fuel, causing excessive soot fouling, Edge is the usual suspect). The dealer (or competent shop with the equipment) can "exercise" the servo and reset the position. At worst, the servo may need replacement. Not the turbo.

This seems to be the only issue now. I have not found anyone yet to "exercise" the servo. I'll repost when I do.
Reply With Quote
  #9  
Old 08-10-2012, 07:00 PM
JohnC's Avatar
JohnC JohnC is offline
Moderator - Enemy of the State
 
Join Date: Jan 2001
Location: New Hampshire - Live Free or Die
Posts: 4,636
Default

Quote:
Originally Posted by Bill Robinson View Post
I also serviced the Air filter while I was in there.
Is it a K&N filter? It is rumored that excess filter oil will cause problems with the MAF sensor.
__________________
JC - Member #1346

"The natural progress of things is for liberty to yield, and government to gain ground." - Thomas Jefferson

2006 D/A extended cab LLY supercomputer
'68 BSA Thunderbolt
'73 Triumph T150V
'04 Triumph Thunderbird Sport
'07 Yukon rolling livingroom
'93 C2500HD 6.5TD-wrecked
'95 K2500 6.5TD, '99 K1500 5.3 SB, '87 F350 7.3 , '78 D150 318 (Sold)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:10 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 1996-2014 by TheDieselPage.com - All Rights Reserved