Thread: P140B code
View Single Post
  #11  
Old 10-25-2018, 02:36 PM
chessy56 chessy56 is offline
Enthusiast
 
Join Date: Jan 2006
Location: South Milwaukee, WI
Posts: 230
Default P-140b

I'm going to throw one more post on this topic as I've been getting these P-140B errors on and off for some time. I got another about a month or so back which made me look at the air filter- it was dirty and within a few thousand miles of its recommended change interval. New filter, cleared the error code and all was OK until driving in heavy rain at highway speeds weeks later- it came back again.

My dealership tech states that GM came out with a bulletin late September stating that they are looking into this issue but don't have a solution yet. GM is telling dealerships to clear the code, make sure the MAF sensor is clean, only OEM air filters are being used (no after market stuff) and send the customer on their way. I'll check with the dealership in a few weeks, but it appears GM is OK with ignoring the check engine lamp if it's only a P-140B.
__________________
"Chessy56"
So. Milwaukee, WI
'01 2500HD, LB7, 440K miles
"Stock" engine. Dual fuel filtration system with Kennedy lift pump, BF Goodrich Commercial T/A Traction tires (sold to a dude from Texas- it's living a warmer life just fine down there now!).

'17 2500HD, L5P (Happy Birthday/Merry Christmas to me!!!) Currently bone stock, 90K miles.

"Socialism is a philosophy of failure, the creed of ignorance and
the gospel of envy. Its inherent virtue is the equal sharing of misery."
Winston Churchill
Reply With Quote