Page 2 of 2 FirstFirst 12
Results 21 to 24 of 24

Thread: Rebuilt 6.2 Lost Power After 600 Miles

  1. #21
    Join Date
    Feb 2000
    Location
    Montana
    Posts
    11,003

  2. #22
    Join Date
    Apr 2001
    Location
    Newberg Oregon
    Posts
    11,494

    Default

    An injector that is peeing a stream will do it as well.
    (1) 1995 Suburban 2500 4x4
    (1) 1997 Astro
    (1) 2007 Chevy Avalanche
    THIS IS BOW TIE COUNTRY

  3. #23
    Join Date
    Feb 2000
    Location
    Montana
    Posts
    11,003

    Default

    Quote Originally Posted by Robyn View Post
    An injector that is peeing a stream will do it as well.
    These fuel injection pumps are volumetric in fuel delivery (limited by the volume of its pumping plungers per stroke). Sure, they can leak fuel over a longer injection interval (knock, smoke and roughness, like the injector I found in our 6.5) but total fuel delivery per power stroke can't be a lot different than the other fuel injectors.

    The high-pressure-common-rail injection systems like that used in the Duramax/Cummins and others could theoretically turn a leaking fuel injector into a constant ON fire-breathing blowtorch, because fuel delivery isn't volumetric.

  4. #24
    Join Date
    Apr 2001
    Location
    Newberg Oregon
    Posts
    11,494

    Default

    The issue is....If the injector is not spraying a nice clean "cone" of fuel, but instead shooting a pee stream and it is landing right on the Glow plug.....this can destroy the plug and also lead to torched piston crown too..

    I agree on the common rail scenario.....

    Low pop pressure squirts with poor spray patterns can do a lot of damage as well as smoke and be a general nuisance....

    They will however do a fine job of dealing with the "Skeeters"
    (1) 1995 Suburban 2500 4x4
    (1) 1997 Astro
    (1) 2007 Chevy Avalanche
    THIS IS BOW TIE COUNTRY

Similar Threads

  1. Lost power?
    By tbeavers in forum 6.2L Diesel - Tech Support - Troubleshooting - Performance
    Replies: 12
    Last Post: 06-16-2015, 13:00
  2. Lost power after ran empty
    By waynep in forum 6.5L Turbo Diesel - Tech Support - Troubleshooting - Performance
    Replies: 3
    Last Post: 12-09-2011, 09:10
  3. Lost power
    By Pogust in forum 6.5L Turbo Diesel - Tech Support - Troubleshooting - Performance
    Replies: 25
    Last Post: 11-27-2011, 20:29
  4. Lost power...
    By flatbottom in forum Duramax 6600
    Replies: 3
    Last Post: 02-25-2008, 10:17
  5. Lost Power Assist
    By LandTug in forum 6.5L Turbo Diesel - Tech Support - Troubleshooting - Performance
    Replies: 3
    Last Post: 01-03-2006, 18:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •