Results 1 to 11 of 11

Thread: P0674 Glow plugs

  1. #1
    Join Date
    Jan 2001
    Location
    Knoxville,Tennessee
    Posts
    2,519

    Default P0674 Glow plugs

    I know I posted about this about September 2018 but I can't find it.

    Back then I replaced #4 glow plug but still kept getting SEL with new plug. After changing the glow plug twice I still got P0674. So I determined it was probably the GP Controller. Changed it still same problem. Not so bad when its warm enough they don't cycle so now SEL.

    Now recently I started getting P0678. Today I decided to fix it once and for all. Did some research and figured I could figure things out. Pulled #4 get 0.6 ohms on it. Same on #8. Well lets try #2 its working and its the same.

    Key off I have 0.9 volts going to all 3 leads when disconnected. Key on 2.4 volts. Start and when plugs cycle 11.4 volts then drops back to 2.4 volts.

    Started it with #2 disconnected and got P0672, P0674, and P0678. Cleared again P0672 is gone but P0674 and P0678 keep coming back and setting SEL.
    Tomorrow I plan on disconnecting both batteries and grounding positive leads for an hour. Did that after I replaced the GP Controller just hoping it will work this time.

    Any other suggestions?
    "The Constitution is not an instrument for the government to restrain the people, it is an instrument for the people to restrain the government."
    -Patrick Henry


    A5150nut
    2006 K3500 D/A
    94 6.5 4x4 5spd Sold

  2. #2
    Join Date
    Feb 2000
    Location
    Montana
    Posts
    11,152

    Default

    Ohms and/or Voltage can each provide a good indication for correct operation, but current flow (amps) is the best test for a glow plug. Insert your ammeter in series with the glow plug wiring at the glow plug. Measuring the amps at a couple "known good" plugs during a key cycle test will help to evaluate any suspect plugs.

    For example... 1- a glow plug controller could appear to function correctly, when applying battery power to the 8 gp circuits, but one or more circuits could fail to pass full current when asked to. 2- GP systems usually employ fusible link wiring to help protect the GP controller system. Fusible links keep the gp wiring from melting if a glow plug were to become shorted (for example). Fusible links can fail in a way that might present as intermittent.

  3. #3
    Join Date
    Jan 2001
    Location
    Knoxville,Tennessee
    Posts
    2,519

    Default

    OK that makes sense. Digital meters can read trace voltage. What kind of amperage should I expect so I dont burn up my meter? And where are these fusible links? I know the harness is part of of the main harness and $1k.
    "The Constitution is not an instrument for the government to restrain the people, it is an instrument for the people to restrain the government."
    -Patrick Henry


    A5150nut
    2006 K3500 D/A
    94 6.5 4x4 5spd Sold

  4. #4
    Join Date
    Jan 2001
    Location
    Knoxville,Tennessee
    Posts
    2,519

    Default

    Got a second code for number 8 not working. Tested them with a test probe and 4 and 8 no glow. Replaced both now for a couple weeks all has been good. That would be the the third GP in 4 and second on 8. Nice to not have to clear codes after first start of the day.
    "The Constitution is not an instrument for the government to restrain the people, it is an instrument for the people to restrain the government."
    -Patrick Henry


    A5150nut
    2006 K3500 D/A
    94 6.5 4x4 5spd Sold

  5. #5
    Join Date
    Apr 2001
    Location
    CA
    Posts
    13,355

    Default

    If the same hole is repeatedly frying (otherwise) good plugs, something is wrong (sorry for stating the obvious). It's either glowing too long, or that hole is too hot, for whatever reason. Traditionally, that spells bad injector, which comes with other liabilities. What do the fried plugs look like, compared to others? Excessive soot, white metal, blisters, deformation?
    1985 Blazer 6.2
    2001 GMC 2500HD D/A
    dmaxmaverick@thedieselpage.com

  6. #6
    Join Date
    Jan 2001
    Location
    Knoxville,Tennessee
    Posts
    2,519

    Default

    Nothing different about No 4 looks same as the others.
    I'm at 128k miles now and very little has had to be done.
    Just thermostats and two glow plugs and a GP controller trying to solve GP problem
    "The Constitution is not an instrument for the government to restrain the people, it is an instrument for the people to restrain the government."
    -Patrick Henry


    A5150nut
    2006 K3500 D/A
    94 6.5 4x4 5spd Sold

  7. #7
    Join Date
    Dec 2000
    Location
    Hawaii/Arizona
    Posts
    253

    Default ceramic glow plugs

    I know this is a bit off point but I see where GM is putting ceramic glow plugs in the Duramax 3.0. I have a 2005 Jeep Liberty with a VM Motori 2.8 Diesel and it came from the factory with ceramic glow plugs. When the ceramic gets old it breaks and falls into the combustion chamber and you have big troubles. DON'T LET ANYONE SELL YOU NEW AND IMPROVED CERAMIC GLOW PLUGS FOR YOUR 6.6 DMAX.

    GM quote
    "Ceramic glow plugs used in the Duramax 3.0L heat up more quickly and hotter than conventional metal-based glow plugs, helping the engine start and heat up more quickly in cold weather."
    *2006 Chevy, 3500, 4X4, DRW, (LBZ) D/A, CC, LT, 252K Miles, 19.5" Wheels, Mag Hytec Transmission Pan and Differential Cover, SS Grill Guard, Racor 2 micron aux fuel filter, 100 Gallon Aux Fuel Tank, using Edge Evolution, Predator Diablosport, Kennedy ECM tune, Fitch Fuel Catalyst.

    *2006 Four Winds, Dutchman, 36', RV, D/A, 5500 Kodiak.
    *1993 Harley Davidson, Turbo charged, Springer Softail.
    *2007 Pontiac Solstice.
    *2005 Jeep, Liberty, CRD (diesel).
    *Full-timing in USA, see America first.

    BUY AMERICAN or CANADIAN, NOTHING from CHINA .

  8. #8
    Join Date
    Feb 2000
    Location
    Montana
    Posts
    11,152

    Default

    Quote Originally Posted by a5150nut View Post
    OK that makes sense. Digital meters can read trace voltage. What kind of amperage should I expect so I dont burn up my meter? And where are these fusible links? I know the harness is part of of the main harness and $1k.
    You'll find a bad fusible link by load testing each GP at its location. Probe the wire that connects to it in series with the other meter probe on the electrical terminal of that GP. If you're measuring a low (lower than the others) amperage, go directly to a battery for power instead of through the GP controller as a test. You only need 3 or so seconds of power application for a good test. The early LB7s used GPs where each bank of four were ganged together. The California versions of the LB7 and all later Duramax engines used individual wires for each glow plug. To see whether the GP controller or the GP wiring could be at fault (assuming you measure a low amperage at one glow plug) you may need to swap wires with another known good glow plug circuit. Who knows, the controller that feeds 8 individual glow plug circuits could be the cause of a single plug not working correctly.

    In the 6.5, for example, the fusible links are built into the harness, either near the GPC or near the GPs. The links are usually just a short piece of light blue and somewhat more flexible wiring - it feels different... 6-10" long or so that are spliced into the wiring. I bought a length of this fusible link at an auto parts store years ago. As I recall, the fusible link is wire sized by cross sectional area of the wire... not by its gauge. So, a 0.5mm2 would be an example. If someone has a bad fusible link, there should be writing on the wire that specifies what size it is.

    The GPs in a 6.5 can each pull about 11 amps. Most digital multimeters I'm familiar with can handle up to 20 amps, which should be more than adequate for a single Duramax GP. Other than an ohm check, I haven't load tested the GPs used in a Duramax. I do know that they are a small diameter "quick heat" variety, so they shouldn't draw more than those used in a 6.5. Let us know what develops... Jim

  9. #9
    Join Date
    Jan 2001
    Location
    Knoxville,Tennessee
    Posts
    2,519

    Default

    Thanks for the follow up MP I have them working now. Replaced 4 and 8 and its been 3 weeks now.
    "The Constitution is not an instrument for the government to restrain the people, it is an instrument for the people to restrain the government."
    -Patrick Henry


    A5150nut
    2006 K3500 D/A
    94 6.5 4x4 5spd Sold

  10. #10
    Join Date
    Feb 2000
    Location
    Montana
    Posts
    11,152

    Default

    Thanks for the followup.

    I suspect the LB7 in my 2001 GMC has a bad glow plug. The 4 plugs in each bank are connected together using a buss bar. That bar will have to be removed to load test each plug... Wish I'd done that before putting the wheel well liners back in last summer.

  11. #11
    Join Date
    Apr 2001
    Location
    CA
    Posts
    13,355

    Default

    If you suspect bad plug(s), the LB7 fed emissions may not set the SES and a code on only one or a couple (CA emissions will fault on one weak plug). If you can read the cycle voltage (simple with a Predator), it will show how many are failed, or open for any reason, but won't show which one. I don't recall them offhand, but I posted the voltage scale some years ago in another thread.
    1985 Blazer 6.2
    2001 GMC 2500HD D/A
    dmaxmaverick@thedieselpage.com

Similar Threads

  1. Glow plugs then and now
    By Robyn in forum 6.5L Turbo Diesel - Tech Support - Troubleshooting - Performance
    Replies: 2
    Last Post: 07-26-2009, 06:38
  2. Glow Plugs
    By MEP in forum Duramax 6600
    Replies: 1
    Last Post: 10-28-2008, 19:29
  3. Six of eight Glow Plugs
    By waynep in forum 6.5L Turbo Diesel - Tech Support - Troubleshooting - Performance
    Replies: 4
    Last Post: 02-21-2007, 13:26
  4. Glow Plugs
    By Jay Mahn in forum 2500HD/3500 HD Trucks & Drivetrain
    Replies: 4
    Last Post: 05-08-2005, 11:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •