TheDieselPage.com Forums  
2018 - TDP's 22nd Anniversary
What's New: | Feature Articles: | Product Reviews: | Member's Area: | Subscribe:
Duramax 6600 Diesel Page | Advertiser's Section | Classified Ads | Photo Album | Diesel Books, GM Licensed T-shirts


Go Back   TheDieselPage.com Forums > The Diesel Page Member Forums > 6.2L Diesel
Register FAQ Members List Photo Album Mark Forums Read

6.2L Diesel 1982-93 6.2L Diesel - Member access forum for any questions or information exchange related to the 6.2L engine.

Reply
 
Thread Tools Display Modes
  #11  
Old 08-03-2017, 08:05 AM
Bigdog Bigdog is offline
Enthusiast
 
Join Date: Jul 2001
Location: Greensboro, NC USA
Posts: 64
Default

I think I finally got my answer. About a week ago, after I stopped at a little market, it wouldn't start again. Turns over ok, but never catches. I'm getting fuel to the injector pump and the glow plugs are fine. I had it towed home. Last weekend, I removed the oil filler tube so that I could see the injector pump end that runs off the camshaft gear. I could see it turning. I hope that, that rules out a timing chain issue.
Soooo, does this basically say that the injector pump has failed and it's time to remove for a rebuild? Is there anything else that I can test to be sure that it's the injector pump?
Thanks for any suggestions and/or replies.
__________________
\'83 Chev 4x4 Suburban; 3/4 ton; <BR>6.5L non turbo; replaced the original 6.2L with new GM motor<BR>4:10 gear<BR>new 700R4 trans <BR>B&M Deep Trans Pan<BR>Autometer Trans Temp Gauge<BR>Rear Heater & A/C
Reply With Quote
  #12  
Old 08-03-2017, 04:02 PM
sctrailrider's Avatar
sctrailrider sctrailrider is offline
Diesel junkie
 
Join Date: Feb 2012
Location: Pauline, SC
Posts: 460
Default

I didn't read every word in this thread again so I'll ask....

When it won't start have you tried pouring cold water on the pump??

If it starts when cold water is poured on it then it's time for another pump...
__________________
1993 Chevy K3500

owner - Twisted Steel Performance

porting, ceramic & powder coating

like us on Facebook
Reply With Quote
  #13  
Old 08-04-2017, 06:02 AM
Robyn's Avatar
Robyn Robyn is offline
Missy Good Wench ( Moderator)
 
Join Date: Apr 2001
Location: Newberg Oregon
Posts: 9,709
Default

Another test is to dump a gallon of 30W motor oil in the tank (Mix with some diesel first)

This will add lubricity and THICKEN the mix some.

If the hot start issue is better then the IP is worn out and needs a rebuild.

A good rebuild requires a head and rotor replacement.

What happens is the plungers and their bores wear out to the point that once they heat up they leak enough that they can't build pressure.

As mentioned COLD WATER ON THE IP can cool things enough that it will start.

If you can spin the engine fast enough (Stick shift being towed/pushed) it would likely start.


Give the oil a shot.

Robyn
__________________
(1) 95 Suburban 2500 4x4
(1) 2017 Mercedes C class
(1) 1997 Astro "CATVAN II"
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 1996-2018 by TheDieselPage.com - All Rights Reserved