TheDieselPage.com Forums  
2018 - TDP's 22nd Anniversary
What's New | Feature Articles | Product Reviews | Member's Area | Free Forum Registration
Duramax 6600 Diesel Page | Advertiser's Section | Classified Ads | The Diesel Page - Publications


Go Back   TheDieselPage.com Forums > 2001-2019 Chevrolet & GMC 2500HD/3500 Light Trucks > Duramax 6600
Register FAQ Members List Photo Album Mark Forums Read

Duramax 6600 Welcome to the Internet's first Duramax 6600 diesel discussion forum for the LB7, LLY, LBZ, LMM, LML, LGH & L5P RPO code engines. Tips on performance, fuel economy, troubleshooting and more.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-11-2018, 07:00 PM
Willcoc Willcoc is offline
Enthusiast
 
Join Date: Mar 2004
Location: New Paris, OH
Posts: 62
Default TCM module failure?

Pulled out of the garage, went to put it in reverse, then doc shows, service Stabilitrack & service traction control.. limp mode, only Idle in forward or reverse, if reverse works. Disconnected batteries, no change. Friend stopped by with code reader, UO101 lost comm with TCM. Based on some search’s, took of frame ground near fuse block, shined up but no change. Pulled connected and reconnected, no change. Anything else before trying to find a replacement?

We think it is the box with spike things on the radiator is module that is the issue.

Not having much luck finding any Internet source for a replacement, so any suggestions short of the dealer?
__________________
2013 D/A 2500HD Crew Cab<> B & W Rollover Ball, Bed cover, def deleted
Reply With Quote
  #2  
Old 05-11-2018, 07:42 PM
rapidoxidationman rapidoxidationman is offline
Enthusiast
 
Join Date: Dec 2002
Location: Teton Valley, Idaho
Posts: 1,636
Default

check the wiring harness with your nose as well as your eyes. It took me some time to find where mice had nested and eaten some wires under the fuse box, disabling my A/C and glow plugs.
__________________
'85 Mercedes Benz 300D, for when I want to be stately.
'05 Mercedes E320 CDI, for when I want to be even statelier.
'05 Chevy K2500 ext cab long box DMax: Everything my '03 was and so much more!

There's no point being a pessimist - it wouldn't work anyway.
Reply With Quote
  #3  
Old 05-15-2018, 09:19 AM
More Power's Avatar
More Power More Power is offline
Administrator
 
Join Date: Feb 2000
Location: Big Sky Country
Posts: 10,336
Arrow

I can't remember the last time someone identified a bad TCM - while possible, they just don't place high on the list of possibilities. I agree with rapidoxidationman that it's more likely due to a wiring issue.

Reseat related connectors, check vehicle grounds, check battery terminals and look for rodents...

I keep Decon rodent bait in my garage.
Reply With Quote
  #4  
Old 05-16-2018, 08:30 AM
Kennedy Kennedy is offline
Long Distance Crew Chief for BMDMAX
 
Join Date: Mar 2000
Location: Loyal WI US
Posts: 10,614
Default

We keep these in stock and program to go for drop in installation. It is primarily a LML thing and seems to be primarily 2011 model year, but there are other years that have issues.

Yes it is on the fan shroud.
__________________
Kennedy Diesel-owner
More than just a salesman-I use and test the products that I sell on a daily basis!
Superflow Lie Detector in house
2002 Chev K2500HD D/A CC Long LT 11.77@ 124mph at 7700# fuel only-e.t. needs help
2005 Chev K3500SRW D/A CC Long LT(SOLD)
2007 Chev K2500 Classic EC Short LT (Sold)
2012 GMC K3500SRW D/A CC Long LTZ Happy Birthday to me! Built 1 working day after my birthday and delivered 7 days later.
2016 GMC K3500SRW D/A CC short LTZ

Custom tuning in house using EFI Live tuning software!
Reply With Quote
  #5  
Old 05-16-2018, 12:04 PM
DmaxMaverick's Avatar
DmaxMaverick DmaxMaverick is offline
Administrator
 
Join Date: Apr 2001
Location: CA
Posts: 12,005
Arrow

I've heard of, but never seen an actual TCM hardware failure (absent known physical damage). It wouldn't surprise me to find that those I've heard of weren't actual failures, at least a vast majority of them. Some firmware versions are more vulnerable to corruption, which is very commonly misdiagnosed as a module failure. In every incident I've seen, a simple calibration update (rewrite/refresh) resolved the issue(s).
__________________
1985 Blazer 6.2
2001 GMC 2500HD D/A
2014 Chevy Cruze Diesel - Fabulous car, no problems at all, but sold Nov. 2016 @ 55K miles.
dmaxmaverick@thedieselpage.com
Reply With Quote
  #6  
Old 05-19-2018, 09:29 AM
Willcoc Willcoc is offline
Enthusiast
 
Join Date: Mar 2004
Location: New Paris, OH
Posts: 62
Default Problem resolved

Was out of town so slow response. Found an online source in Cincinnati for a new TCM with programming. Plugged it in, problem resoLved. Sorry, John, already had it on order before you responded. Have the bad one if somebody wants it.

Good to know it is not a common problem.
__________________
2013 D/A 2500HD Crew Cab<> B & W Rollover Ball, Bed cover, def deleted
Reply With Quote
Reply

Tags
tcm module

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:36 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 1996-2018 by TheDieselPage.com - All Rights Reserved