TheDieselPage.com Forums
 
The Diesel Page Forums

2020 - TDP's 24th Anniversary
What's New | Feature Articles | Product Reviews | Member's Area | Free Forum Registration
Duramax 6600 Diesel Page | Advertiser's Section | Classified Ads | The Diesel Page - Publications


Go Back   TheDieselPage.com Forums > The Diesel Page Forums > 1982-2000 C/K Truck & SUV Chassis & Drivetrain

1982-2000 C/K Truck & SUV Chassis & Drivetrain Discussion Forum for the 1982-2000 GM Pickup Trucks and SUVs, and their Transmissions & Drivetrains, cab, chassis, electrical systems and a lot more.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-23-2020, 07:48 AM
arveetek's Avatar
arveetek arveetek is offline
Moderator-Towing Forum
 
Join Date: Oct 2001
Location: Granby, Missouri, USA
Posts: 2,787
Question Defroster issues

1995 K1500 Tahoe 6.5L diesel

I have been experiencing issues with my defroster this winter. Turning on the defrost actually causes all the windows and windshield to get fogged up. I dread having to use the defrost setting since I know it will make everything worse before it gets better. After about 10 minutes of driving, it finally clears everything up, but I have to leave it on high the entire time for it to work.

I am noticing a musty smell from the vents as well. There must be excess moisture in the HVAC system.

Here's what I've checked:

A/C Compressor is running
Air is coming out of defrost vents normally
I removed the blower motor to check the evaporator, and it is clean
Evaporator drain is open and flowing normally

What do I need to check next? I suspect an issue with the heater core, but I don't appear to be losing any coolant. Haven't had to add any coolant in months.

Thanks,

Casey
__________________
1995 K1500 Tahoe 2 door, 6.5LTD, NP241, 4L80E, 3.42's, 285/75R16 BFG K02's; Kennedy OPS harness, gauges, Quick Heat plugs, and TD-Max chip; Dtech FSD on FSD Cooler; vacuum pump deleted, Turbo Master, 3.5" Kennedy exhaust, F code intake, '97 air box; dual t/stats, HO water pump, Champion radiator; Racor fuel filter; 357K miles and running strong!
Reply With Quote
  #2  
Old 01-23-2020, 08:19 AM
DmaxMaverick's Avatar
DmaxMaverick DmaxMaverick is offline
Administrator
 
Join Date: Apr 2001
Location: CA
Posts: 12,558
Default

Make sure your recirc isn't stuck. Defog mode should force fresh air and disable recirc. If it's stuck, or not cycling properly, it's condensing all the moisture in the cabin onto the glass, until it warms up enough to vaporize it, and condense it again in the evaporator. Other than that, it's likely the heater core. It doesn't take much leakage to fog the glass. A few drops at a time is all it takes, and you may not notice the missing coolant.
__________________
1985 Blazer 6.2
2001 GMC 2500HD D/A
2014 Chevy Cruze Diesel - Fabulous car, no problems at all, but sold Nov. 2016 @ 55K miles.
dmaxmaverick@thedieselpage.com
Reply With Quote
  #3  
Old 01-23-2020, 08:38 AM
arveetek's Avatar
arveetek arveetek is offline
Moderator-Towing Forum
 
Join Date: Oct 2001
Location: Granby, Missouri, USA
Posts: 2,787
Default

Quote:
Originally Posted by DmaxMaverick View Post
Make sure your recirc isn't stuck. Defog mode should force fresh air and disable recirc. If it's stuck, or not cycling properly, it's condensing all the moisture in the cabin onto the glass, until it warms up enough to vaporize it, and condense it again in the evaporator. Other than that, it's likely the heater core. It doesn't take much leakage to fog the glass. A few drops at a time is all it takes, and you may not notice the missing coolant.
DOH! I didn't think of that! The recirc door has been broken (or rather the actuator) for some time, and I've actually wired it closed into the recirculate position for better summer time A/C performance. I will try that first.

Thank you sir!

Casey
__________________
1995 K1500 Tahoe 2 door, 6.5LTD, NP241, 4L80E, 3.42's, 285/75R16 BFG K02's; Kennedy OPS harness, gauges, Quick Heat plugs, and TD-Max chip; Dtech FSD on FSD Cooler; vacuum pump deleted, Turbo Master, 3.5" Kennedy exhaust, F code intake, '97 air box; dual t/stats, HO water pump, Champion radiator; Racor fuel filter; 357K miles and running strong!

Last edited by arveetek; 01-23-2020 at 09:18 AM.
Reply With Quote
  #4  
Old 01-23-2020, 08:42 AM
DmaxMaverick's Avatar
DmaxMaverick DmaxMaverick is offline
Administrator
 
Join Date: Apr 2001
Location: CA
Posts: 12,558
Default

Yep. That'll do it.
__________________
1985 Blazer 6.2
2001 GMC 2500HD D/A
2014 Chevy Cruze Diesel - Fabulous car, no problems at all, but sold Nov. 2016 @ 55K miles.
dmaxmaverick@thedieselpage.com
Reply With Quote
  #5  
Old 01-25-2020, 07:01 AM
trbankii's Avatar
trbankii trbankii is offline
Enthusiast
 
Join Date: Mar 2000
Location: South Central Pennsylvania, USA
Posts: 2,641
Default

Yep, that would do it. Hopefully it isn't the leaking heater core (my first thought) as that's a royal pain to replace.
__________________
'94 GMC 6.5TD K1500 4L80E 2-Door Yukon SLE 221K
'93 Chevrolet 6.5TD K2500HD NV4500 Std. Cab Longbed 187K
'85 Toyota 22R RN60 4x4 Std. Cab Shortbed 178K (Currently retired for rebuild)
Diesel Page Member #2423
Reply With Quote
  #6  
Old 01-25-2020, 08:37 PM
arveetek's Avatar
arveetek arveetek is offline
Moderator-Towing Forum
 
Join Date: Oct 2001
Location: Granby, Missouri, USA
Posts: 2,787
Default

I've only driven it 3 or 4 times since moving the recirc door, but crossing my fingers... so far so good.

Casey
__________________
1995 K1500 Tahoe 2 door, 6.5LTD, NP241, 4L80E, 3.42's, 285/75R16 BFG K02's; Kennedy OPS harness, gauges, Quick Heat plugs, and TD-Max chip; Dtech FSD on FSD Cooler; vacuum pump deleted, Turbo Master, 3.5" Kennedy exhaust, F code intake, '97 air box; dual t/stats, HO water pump, Champion radiator; Racor fuel filter; 357K miles and running strong!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Several starting/running issues before my move GMC Hauler 6.5L Turbo Diesel - Tech Support - Troubleshooting - Performance 34 11-29-2010 03:14 PM
2011 LML and B&W Hitch issues cowboywildbill Towing - 5th-Wheels & Travel-Trailers 6 11-24-2010 10:34 AM
Pmd Issues Must Read SFRESCUE 6.5L Turbo Diesel - Tech Support - Troubleshooting - Performance 29 07-13-2010 05:21 PM
Boost Issues ercaduceus 6.5L Turbo Diesel - Tech Support - Troubleshooting - Performance 4 08-09-2008 01:17 AM
IP Issues PVSLS400 6.5L Turbo Diesel - Tech Support - Troubleshooting - Performance 2 02-06-2007 05:37 AM


All times are GMT -7. The time now is 05:22 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 1996-2020 by TheDieselPage.com - All Rights Reserved