TheDieselPage.com Forums
 
The Diesel Page Forums

2019 - TDP's 23rd Anniversary
What's New | Feature Articles | Product Reviews | Member's Area | Free Forum Registration
Duramax 6600 Diesel Page | Advertiser's Section | Classified Ads | The Diesel Page - Publications


Go Back   TheDieselPage.com Forums > 2001-2019 Chevrolet & GMC 2500HD/3500 Light Trucks > Duramax 6600
Register FAQ Members List Photo Album Mark Forums Read

Duramax 6600 Welcome to the Internet's first Duramax 6600 diesel discussion forum for the LB7, LLY, LBZ, LMM, LML, LGH & L5P RPO code engines. Tips on performance, fuel economy, troubleshooting and more.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-22-2019, 09:39 PM
2001gmc36 2001gmc36 is offline
Newbie
 
Join Date: May 2019
Location: Texas
Posts: 2
Exclamation Crank but no start

I have a 2001 gmc 6.6 duramax a few months ago when it would get below 50 degrees it would not go into gear when it had set over night , everything moved properly but it would not ingage. So I would put it into park and wait 10-15 minutes with it running put it in gear and it drove with no issues. I checked the transmission fluid and it was perfect. I read the nsbu's go bad and I bought one and it seemed to work but it still has problems every now and again but once it goes into gear it runs drives shiftes just fine and will not usually do it again unless it sits for a while or gets really cold. About a month later it was geting warmer and now it was getting harder to start but once it did start it ran good. So I bought a lift pump again that's what I kept reading about and that seemed to fix it for awhile but now Then i can take a 20 min drive shut it off And run into the store and came back and it will crank but wouldn't start so I opened the hood and checked if I had any leaks and everything looked fine. Waited probably 30-45 minutes and it started up no problem I thought it was a freak thing so I didn't think twice but now it is happening more often and the only trick I could do to fix it was hold the pedal to the floor and it would start and run and drive fine. So I started today and had to run errands and I never shut it off it ran great got on the highway great idled great then when I got back to the shop shut it off I tried to start it back and it would not start and hours later still will not start still cranks but won't start the primer pump is hard but there is no pressure on the fuel rail unless I turn the key on so the lift pump is on. The thing that really puzzles me about all of this is once it starts and goes into gear it runs and drives just fine no problems until I shut it off. The only codes I get are p0845,p0846,p0841,P1713 and the check engine light does not stay on long it will go off with out being cleared. I was told it might be my CPU has gone bad because I had a edge programmer on it. Does anyone have any ideas what might be going on. And I have already replaced the injectors and injection pump about 57,000 miles ago. Any ideas or help appreciated thank!
Reply With Quote
 

Tags
2001, duramax, fuel, start

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:53 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 1996-2019 by TheDieselPage.com - All Rights Reserved