TheDieselPage.com Forums
 
The Diesel Page Forums

2019 - TDP's 23rd Anniversary
What's New | Feature Articles | Product Reviews | Member's Area | Free Forum Registration
Duramax 6600 Diesel Page | Advertiser's Section | Classified Ads | The Diesel Page - Publications


Go Back   TheDieselPage.com Forums > The Diesel Page Forums > 6.2L Diesel

6.2L Diesel 1982-93 6.2L Diesel - Welcome to the Internet's first discussion forum for the 6.2L engine.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-02-2019, 09:32 PM
sdelaney's Avatar
sdelaney sdelaney is offline
Enthusiast
 
Join Date: Aug 2019
Location: Joliet, Illinois
Posts: 16
Default White Smoke On Passenger Side

The other day I noticed white smoke in the passenger side exhaust on start up. It's ONLY the passenger side, nothing on the drivers side. It doesn't last long (just until the engine is warm) and only happens if the truck has been sitting overnight.

I never noticed it before and the only reason I noticed it this time is because I had to get out of the truck to get something right after I started it.

The engine runs a little rough on start up but smooths out before I even get to the end of the block.

While trying to figure this out I noticed a few air bubbles in the IP return line before a cold start.

The engine runs fine otherwise. No blowby.

What the heck would make the smoke come out the passenger side only, and do the few (VERY few) air bubbles in the IP return line have anything to do with it?

While we're at it, how do you go about locating such a tiny air leak in the fuel system?

Thanks
Reply With Quote
  #2  
Old 10-03-2019, 02:53 AM
trbankii's Avatar
trbankii trbankii is offline
Enthusiast
 
Join Date: Mar 2000
Location: South Central Pennsylvania, USA
Posts: 2,624
Default

Welcome to the forum.

You don't give any particulars about your truck, but since you're in the 6.2 forum I'm going to say that it is at least a 1993 - or possibly older - truck.

For the bubbles, the first suspicion is the return lines themselves. They may be allowing air to enter the return side of things without any drivability issues connected to the supply side. There are kits to replace the "soft" return lines. Check the lines general condition and along them for any "oily" signs that would show a leak.

The other year I had to replace the "hard" supply lines in my 1993 6.5TD due to leaks. Yours is as old (or older) than mine, so leaks are a distinct possibility. After checking the return lines, I'd suggest again to check along the supply lines from tank to engine for any "oily" spots that would show fuel leaking. If the lines run similar to the 6.5TD, this can be an issue where they "disappear" where they go to the tank and where they run up the transmission tunnel to the engine bay, but the condition of the lines elsewhere should give you some idea of the overall condition.

When I removed the lines in my truck, they were in much, much worse condition than I had even realized. In taking them out, they just crumbled in places. I was pretty amazed that they were delivering any fuel for as long as they did.

As for the white smoke, white is typically a sign of coolant entering the cylinders - either a head gasket or crack in the block. As for why only the passenger side - there is a separate head gasket for each side of the block, so only one could be leaking. It can even be leaking around only a single cylinder. A crack in the block would also obviously be localized and not affect both sides.
__________________
'94 GMC 6.5TD K1500 4L80E 2-Door Yukon SLE 221K
'93 Chevrolet 6.5TD K2500HD NV4500 Std. Cab Longbed 187K
'85 Toyota 22R RN60 4x4 Std. Cab Shortbed 178K (Currently retired for rebuild)
Diesel Page Member #2423
Reply With Quote
  #3  
Old 10-03-2019, 05:22 AM
JohnC's Avatar
JohnC JohnC is offline
Proud Deplorable
 
Join Date: Jan 2001
Location: New Hampshire - Live Free or Die
Posts: 5,466
Default

Wow! Talk about negativity! It could also be a bad glow plug, or a bad injector spray pattern causing the white smoke.

No help on the bubbles, although I think a bad injector could cause that, too.
__________________
"Need" - Wanting to get someone else's money.
"Greed" (formerly meant what "need" means today) - wanting to keep your own.
"Compassion" - a politician's willingness to arrange the transfer.
-Joseph Sobran

Current oil burners: MB 350SDL, Kubota 7510
Gone but not forgotten: '87 F350 7.3, '93 C2500 6.5, '95 K2500 6.5, '06 K2500HD 6.6
Reply With Quote
  #4  
Old 10-03-2019, 05:52 AM
sdelaney's Avatar
sdelaney sdelaney is offline
Enthusiast
 
Join Date: Aug 2019
Location: Joliet, Illinois
Posts: 16
Default

It's an 83 C20 (sorry, I thought I had that info in my signature line).

Since I just installed new 60g's last month I don't think it's the glow plugs.

Seems to me if coolant were entering the cylinders that would likely be a constant thing, not isolated to morning cold start.

I've only owned the truck for about 4 months so I have no idea how old the injectors are. Guess it's time for some new ones.

Thanks
Reply With Quote
  #5  
Old 10-03-2019, 06:16 AM
DmaxMaverick's Avatar
DmaxMaverick DmaxMaverick is offline
Administrator
 
Join Date: Apr 2001
Location: CA
Posts: 12,370
Arrow

Quote:
Originally Posted by sdelaney View Post
It's an 83 C20 (sorry, I thought I had that info in my signature line).

Since I just installed new 60g's last month I don't think it's the glow plugs.
That, plus colder starting temps leads to rough(er) starts. The 60's often need a longer glow cycle for good starts in cold weather. They don't get as hot as earlier/other plugs. Try a double cycle of the plugs. Key on until the GP lamp goes out. Key off, then on again for another cycle, then start. A normal cycle should be about 8-10 seconds. 60G's require at least that to get hot.

Quote:
Seems to me if coolant were entering the cylinders that would likely be a constant thing, not isolated to morning cold start.

I've only owned the truck for about 4 months so I have no idea how old the injectors are. Guess it's time for some new ones.

Thanks
Injectors are easy to replace, and relatively inexpensive. About the simplest repair to refresh an old engine. Look for quality from known suppliers, before trying to save a little money. Ebay sellers lie, for the most part. A quality rebuilt injector is better than unknown new.

Weak injectors and poor injectors result in smokey/rough starts.
__________________
1985 Blazer 6.2
2001 GMC 2500HD D/A
2014 Chevy Cruze Diesel - Fabulous car, no problems at all, but sold Nov. 2016 @ 55K miles.
dmaxmaverick@thedieselpage.com
Reply With Quote
  #6  
Old 10-03-2019, 11:13 AM
sdelaney's Avatar
sdelaney sdelaney is offline
Enthusiast
 
Join Date: Aug 2019
Location: Joliet, Illinois
Posts: 16
Default

I was looking at a set of new Delphi on Amazon for $219. Any reason to stay away from those?
Reply With Quote
  #7  
Old 10-05-2019, 09:04 AM
trbankii's Avatar
trbankii trbankii is offline
Enthusiast
 
Join Date: Mar 2000
Location: South Central Pennsylvania, USA
Posts: 2,624
Default

Quote:
Originally Posted by JohnC View Post
Wow! Talk about negativity!
Sorry, I guess "white" smoke meant coolant to me. The other causes are more grey to me.

A second vote for injectors from Kennedy Diesel. More costly than bargain shopping, but you'll know what you're getting and you'll have the service after the sale.
__________________
'94 GMC 6.5TD K1500 4L80E 2-Door Yukon SLE 221K
'93 Chevrolet 6.5TD K2500HD NV4500 Std. Cab Longbed 187K
'85 Toyota 22R RN60 4x4 Std. Cab Shortbed 178K (Currently retired for rebuild)
Diesel Page Member #2423
Reply With Quote
  #8  
Old 10-06-2019, 06:51 AM
Robyn's Avatar
Robyn Robyn is offline
Missy Good Wench ( Moderator)
 
Join Date: Apr 2001
Location: Newberg Oregon
Posts: 10,371
Default

I agree on the injectors.

Old injectors lose several things over time/miles

Pop pressure drops as does the quality of the spray pattern.

Likely you have some injectors that are popping at way too low of a pressure and are squirting a pee stream instead of a nice fine mist in a cone pattern.

Give JOHN KENNEDY A SHOUT


What I do is have a local shop that does topnotch work build me a set, and on an older rig I usually set the pop pressure towards the lower end of spec to avoid issues that can arise from an injector pump that has seen many miles and it's pressure ability may be a tad lower than optimal..

This CAN help with hot no start issues due to internal leaks in the plungers.

STAY AWAY from ebay on this stuff....

Good luck
__________________
(1) 1995 Suburban 2500 4x4
(1) 1997 Astro
(1) 2007 Chevy Avalanche
THIS IS BOW TIE COUNTRY
Reply With Quote
  #9  
Old 10-07-2019, 09:38 PM
sdelaney's Avatar
sdelaney sdelaney is offline
Enthusiast
 
Join Date: Aug 2019
Location: Joliet, Illinois
Posts: 16
Default

Hey thanks for all the help and advice!

I put in a set of Delphi injectors and . . . WOW!

I must have really needed them because the truck runs so much smoother and seems much more responsive.

Actually, I put in seven of them. The last one, on the driver's side by the firewall, I couldn't get to with my socket because the shift linkage is in the way.

Is there any trick to doing that that doesn't involve removing the shift linkage?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:03 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1996-2019 by TheDieselPage.com - All Rights Reserved